Elevated response times when creating or updating records

Incident Report for Akeneo

Resolved

The elevated response times when creating or updating records are now resolved, and all services are operating normally. The fix we deployed has proven effective.
We sincerely apologize for the disruption this caused.

Thank you for your patience.
Posted Mar 03, 2026 - 23:00 CET

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 20:20 CET

Investigating

We are currently observing increased response times when saving products and product models via both the UI and API, since 7am CET today.

At this time, approximately 0.1% of traffic for these operations is impacted, almost exclusively on Western Europe (GCP europe-west1 region).

Our team is actively investigating the issue and will provide additional updates as soon as more information becomes available.
Posted Mar 03, 2026 - 14:54 CET
This incident affected: PIM SaaS (UI, REST API).