Latency on import and export jobs in the Western European region

Incident Report for Akeneo

Resolved

The incident has been resolved, and all import and export jobs in Western Europe are now being processed as expected.
Posted Apr 21, 2026 - 17:01 CEST

Monitoring

We have identified an issue in which some users in the Western European region are experiencing increased latency across all exports and all imports except product imports. The issue began around 2:00 PM CEST on April 21st, 2026.

Our engineering team has identified the root cause within our infrastructure and has implemented a fix to mitigate the issue. We will continue monitoring the situation and provide an update within 1 hour.
Posted Apr 21, 2026 - 16:38 CEST
This incident affected: PIM SaaS (UI).