Workflow UI Freezing During Enrichment Operations

Incident Report for Akeneo

Resolved

The fix has been deployed and we have confirmed that the Workflow feature is now working as expected.
We apologize for the disruption.
Posted Apr 23, 2026 - 20:05 CEST

Monitoring

A fix is being deployed for this issue and we are monitoring the results.
Posted Apr 23, 2026 - 19:45 CEST

Identified

Since 12:30 UTC, users are experiencing performance issues with the Workflow feature.

When performing enrichment operations, the Workflow UI may become completely unresponsive. All users of the Workflow feature are affected.

API Workflow enrichment remains operational.

We have identified the issue and are currently working on deploying the fix in production. We will update you within 60 minutes.
Posted Apr 23, 2026 - 18:07 CEST
This incident affected: PIM SaaS (UI).